Create Method


Creates a new view for the systems analysis report.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020.1

Syntax

C#
public static ViewSystemsAnalysisReport Create(
	Document document,
	string viewName
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	viewName As String _
) As ViewSystemsAnalysisReport
Visual C++
public:
static ViewSystemsAnalysisReport^ Create(
	Document^ document, 
	String^ viewName
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document where the view is to be created.
viewName
Type: SystemString
The name of the new report view.

Return Value

The newly created view instance, or a null reference (Nothing in Visual Basic) if the operation fails.

Remarks

A report instance is typically created to request a new systems analysis. The default values include the weather file "USA_CO_Denver.Intl.AP.725650_TMY3.epw" and the workflow file "HVAC Systems Loads and Sizing.osw". Both are part of the Revit installation. The default output folder is the system TEMP folder.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException viewName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- viewName is an empty string.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also