Creates a new duct from two points.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- systemTypeId
- Type: Autodesk.Revit.DBElementId
The id of the HVAC system type.
- ductTypeId
- Type: Autodesk.Revit.DBElementId
The id of the duct type.
- levelId
- Type: Autodesk.Revit.DBElementId
The level ElementId for the duct.
- startPoint
- Type: Autodesk.Revit.DBXYZ
The start point of the duct.
- endPoint
- Type: Autodesk.Revit.DBXYZ
The end point of the duct.
Return Value
The created duct.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The systemTypeId is not valid HVAC system type. -or- The duct type ductTypeId is not valid duct type. -or- The ElementId levelId is not a Level. -or- The points of startPoint and endPoint are too close: for MEPCurve, the minimum length is 1/10 inch. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |