FindNearest Method


Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public ReferenceWithContext FindNearest(
	XYZ origin,
	XYZ direction
)
Visual Basic
Public Function FindNearest ( _
	origin As XYZ, _
	direction As XYZ _
) As ReferenceWithContext
Visual C++
public:
ReferenceWithContext^ FindNearest(
	XYZ^ origin, 
	XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DBXYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DBXYZ
The direction of the ray.

Return Value

The intersected reference nearest to the ray origin, a null reference (Nothing in Visual Basic) if none is found

Remarks

Note that FindNearest() is a convenience method, and other references that may be nearly the same distance from the origin can be obtained from Find(XYZ, XYZ).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also