SetValueAsDoubles Method


Sets the value of the property.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public void SetValueAsDoubles(
	IList<double> value
)
Visual Basic
Public Sub SetValueAsDoubles ( _
	value As IList(Of Double) _
)
Visual C++
public:
void SetValueAsDoubles(
	IList<double>^ value
)

Parameters

value
Type: System.Collections.GenericIListDouble
The new value as doubles.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input value is invalid for this AssetPropertyDoubleArray4d property.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The asset property is not editable.

See Also