Factory method - creates analysis display style object of type Vectors for the given document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
Document for which analysis display style object is created.
- name
- Type: SystemString
Name of the analysis display style within the %document%.
- vectorSettings
- Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayVectorSettings
Vector settings for the style.
- colorSettings
- Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayColorSettings
Color settings for the style.
- legendSettings
- Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayLegendSettings
Legend settings for the style.
Return Value
New analysis display style object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | document is a family. -or- name is not unique in document. |