NewOpening Method (Level, Level, CurveArray)


Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
	Level bottomLevel,
	Level topLevel,
	CurveArray profile
)
Visual Basic
Public Function NewOpening ( _
	bottomLevel As Level, _
	topLevel As Level, _
	profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
	Level^ bottomLevel, 
	Level^ topLevel, 
	CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.DBLevel
bottom level
topLevel
Type: Autodesk.Revit.DBLevel
top level
profile
Type: Autodesk.Revit.DBCurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the bottom level does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the top level does not exist in the given document.

See Also