Sets if elements of the given category will be visible in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DBElementId
The ID of the category.
- hide
- Type: SystemBoolean
True to make elements of this category invisible, false to make them visible.
Remarks
This affects only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
- The category classes settings for model categories, annotation categories, import categories or analytical model categories.
- View filters.
- Elements hidden individually in the view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | categoryId does not correspond to a Category. -or- Category cannot be hidden. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |