Creates a new flexible pipe into the document, using a point array and flex pipe type.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- systemTypeId
- Type: Autodesk.Revit.DBElementId
The id of the piping system type.
- pipeTypeId
- Type: Autodesk.Revit.DBElementId
The id of the flexible pipe.
- levelId
- Type: Autodesk.Revit.DBElementId
The level id for the flexible pipe.
- points
- Type: System.Collections.GenericIListXYZ
The point array indicating the path of the flexible pipe, including the end point.
Return Value
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The systemTypeId is not valid piping system type. -or- The type pipeTypeId is not valid flexible pipe type. -or- The ElementId levelId is not a Level. -or- The valid number of points is less than two. In order to create a flex curve, at least two points are required. Note the duplicate points don't take into account. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |