GetExternalGeometryId Method


Retrieves the ExternalGeometryId associated with the reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ExternalGeometryId GetExternalGeometryId()
Visual Basic
Public Function GetExternalGeometryId As ExternalGeometryId
Visual C++
public:
ExternalGeometryId^ GetExternalGeometryId()

Remarks

If an ExternalGeometryId has not been set, this method returns a null reference (Nothing in Visual Basic).

See Also