Equals Method


Determines whether this ForgeTypeId is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public override bool Equals(
	Object other
)
Visual Basic
Public Overrides Function Equals ( _
	other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
	Object^ other
) override

Parameters

other
Type: SystemObject
The ForgeTypeId with which to compare this ForgeTypeId.

Return Value

True if the given ForgeTypeId is equal to this one, or false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was NULL

See Also