CreateGeometryInstance Method


Creates a copy of a definition shape that was created earlier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static IList<GeometryObject> CreateGeometryInstance(
	Document document,
	string definition_id,
	Transform trf
)
Visual Basic
Public Shared Function CreateGeometryInstance ( _
	document As Document, _
	definition_id As String, _
	trf As Transform _
) As IList(Of GeometryObject)
Visual C++
public:
static IList<GeometryObject^>^ CreateGeometryInstance(
	Document^ document, 
	String^ definition_id, 
	Transform^ trf
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Document to which the created element will be added
definition_id
Type: SystemString
ID of the shape definition that was created earlier and stored via DirectShapeLibrary
trf
Type: Autodesk.Revit.DBTransform
Transform to be applied to the definition

Return Value

A collection of GeometryObjects representing a placed instance of the pre-defined shape The caller function takes ownership

Remarks

Use DirectShapeLibrary class to store definitions prior to using them here. How the definitions are stored will determine whether an instance or a copy of the shape will be created. Use the output of this function as input to CreateElement to make the created shape persistent. This is intended to support a definition/instance pattern common in CAD formats - DWG blocks, STEP MAPPED_ITEM, IFC IfcMappedItem.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also