CreateCreasesFromFoldingLines Method


Convert selected folding lines to split lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public void CreateCreasesFromFoldingLines(
	Element hostObj,
	IList<Reference> references
)
Visual Basic
Public Sub CreateCreasesFromFoldingLines ( _
	hostObj As Element, _
	references As IList(Of Reference) _
)
Visual C++
public:
void CreateCreasesFromFoldingLines(
	Element^ hostObj, 
	IList<Reference^>^ references
)

Parameters

hostObj
Type: Autodesk.Revit.DBElement
object that hosts the SlabShapeEditor
references
Type: System.Collections.GenericIListReference
References of selected folding lines.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException this operation failed.

See Also