Create Method


Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static BRepBuilderSurfaceGeometry Create(
	Surface surface,
	BoundingBoxUV surfaceEnvelope
)
Visual Basic
Public Shared Function Create ( _
	surface As Surface, _
	surfaceEnvelope As BoundingBoxUV _
) As BRepBuilderSurfaceGeometry
Visual C++
public:
static BRepBuilderSurfaceGeometry^ Create(
	Surface^ surface, 
	BoundingBoxUV^ surfaceEnvelope
)

Parameters

surface
Type: Autodesk.Revit.DBSurface
The Revit surface defining the geometry. This BRepBuilderSurfaceGeometry stores a copy of the input surface.
surfaceEnvelope
Type: Autodesk.Revit.DBBoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException A surface of this type can not be used as a part of the geometry generated by BRepBuilder.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also