WallSweep Class


Represents a wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public class WallSweep : HostObject
Visual Basic
Public Class WallSweep _
	Inherits HostObject
Visual C++
public ref class WallSweep : public HostObject

Remarks

This element may represent either a standalone sweep or reveal element created by the Revit user interface or API, or a "fixed" wall sweep or reveal that was created by the contents of a wall's compound structure.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBHostObject
      Autodesk.Revit.DBWallSweep

See Also