IsJoinAllowedAtEnd Method


Identifies if the indicated end of the framing element is allowed to join to others.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool IsJoinAllowedAtEnd(
	FamilyInstance familyInstance,
	int end
)
Visual Basic
Public Shared Function IsJoinAllowedAtEnd ( _
	familyInstance As FamilyInstance, _
	end As Integer _
) As Boolean
Visual C++
public:
static bool IsJoinAllowedAtEnd(
	FamilyInstance^ familyInstance, 
	int end
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance, which must be of a structural framing category.
end
Type: SystemInt32
The index of the end (0 for the start, 1 for the end).

Return Value

True if it is allowed to join. False if it is disallowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException end must be 0 or 1.
Autodesk.Revit.ExceptionsArgumentsInconsistentException The input familyInstance is not of a structural framing category.

See Also