EdgeEndPoint Constructor (Edge, Int32)


Constructs an instance of EdgeEndPoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public EdgeEndPoint(
	Edge edge,
	int index
)
Visual Basic
Public Sub New ( _
	edge As Edge, _
	index As Integer _
)
Visual C++
public:
EdgeEndPoint(
	Edge^ edge, 
	int index
)

Parameters

edge
Type: Autodesk.Revit.DBEdge
The Edge.
index
Type: SystemInt32
Use 0 for the start point, 1 for the end point of an Edge.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The given value for index is not 0 or 1.

See Also