LightingSource Property


The lighting scheme type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public LightingSource LightingSource { get; set; }
Visual Basic
Public Property LightingSource As LightingSource
	Get
	Set
Visual C++
public:
property LightingSource LightingSource {
	LightingSource get ();
	void set (LightingSource value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also