GetUnscaledTransformWithoutFixOfDirection Method


Obtains the unscaled transform from an IfcLocalPlacement handle without fix of direction.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static Transform GetUnscaledTransformWithoutFixOfDirection(
	ExporterIFC exporterIFC,
	IFCAnyHandle placement
)
Visual Basic
Public Shared Function GetUnscaledTransformWithoutFixOfDirection ( _
	exporterIFC As ExporterIFC, _
	placement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetUnscaledTransformWithoutFixOfDirection(
	ExporterIFC^ exporterIFC, 
	IFCAnyHandle^ placement
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
placement
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The placement handle.

Return Value

The transform.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also