Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Examples

string versionInfo = application.VersionBuild + "\n"
+ application.VersionName + "\n"
+ application.VersionNumber;

Dim versionInfo As String = (application.VersionBuild + vbLf + application.VersionName & vbLf) + application.VersionNumber
Inheritance Hierarchy
SystemObject
Autodesk.Revit.ApplicationServicesApplication
Autodesk.Revit.DB.MacrosApplicationEntryPoint
Autodesk.Revit.ApplicationServicesApplication
Autodesk.Revit.DB.MacrosApplicationEntryPoint