InitCheck Method


Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
void InitCheck(
	Document document
)
Visual Basic
Sub InitCheck ( _
	document As Document _
)
Visual C++
void InitCheck(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Document for which performance problems are being checked.

See Also