AnalysisType Property


The type of analysis mode.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public AnalysisMode AnalysisType { get; set; }
Visual Basic
Public Property AnalysisType As AnalysisMode
	Get
	Set
Visual C++
public:
property AnalysisMode AnalysisType {
	AnalysisMode get ();
	void set (AnalysisMode value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The analysis type does not fall within an appropriate range.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also