Sets the default resolution type for the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- type
- Type: Autodesk.Revit.DBFailureResolutionType
The type of resolution to be used as default.
Remarks
If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Resolution of the type is not applicable to the failure. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions. |