IsPointInRoom Method


Determines if a point lies within the volume of the room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsPointInRoom(
	XYZ point
)
Visual Basic
Public Function IsPointInRoom ( _
	point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInRoom(
	XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DBXYZ
Point to be checked.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the point is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException The coordinates of the point is not a number.

See Also