AddRule Method


Adds a performance adviser rule to the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void AddRule(
	PerformanceAdviserRuleId id,
	IPerformanceAdviserRule rule
)
Visual Basic
Public Sub AddRule ( _
	id As PerformanceAdviserRuleId, _
	rule As IPerformanceAdviserRule _
)
Visual C++
public:
void AddRule(
	PerformanceAdviserRuleId^ id, 
	IPerformanceAdviserRule^ rule
)

Parameters

id
Type: Autodesk.Revit.DBPerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
rule
Type: Autodesk.Revit.DBIPerformanceAdviserRule
The rule to be added

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also