LoadSet Property


The electrical analytical load set of the analytical equipment load.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId LoadSet { get; set; }
Visual Basic
Public Property LoadSet As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ LoadSet {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

invalidElementId if the analytical equipment load does not belong to any analytical load sets.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The given element id loadSetId is neither a load set id nor invalidElementId.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also