FootPrintRoof Class


Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic
Public Class FootPrintRoof _
	Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBHostObject
      Autodesk.Revit.DBRoofBase
        Autodesk.Revit.DBFootPrintRoof

See Also