FamilySymbol of the annotation to use for this connection type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familySymbolId
- Type: Autodesk.Revit.DBElementId
Remarks
The FamilySymbol must be of category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to this type's applyTo property. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |