DocumentEntryPoint Class


For Revit Macros use only.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public abstract class DocumentEntryPoint : Document, 
	IEntryPoint
Visual Basic
Public MustInherit Class DocumentEntryPoint _
	Inherits Document _
	Implements IEntryPoint
Visual C++
public ref class DocumentEntryPoint abstract : public Document, 
	IEntryPoint

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBDocument
    Autodesk.Revit.DB.MacrosDocumentEntryPoint

See Also