PathOfTravel Class


An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public class PathOfTravel : Element
Visual Basic
Public Class PathOfTravel _
	Inherits Element
Visual C++
public ref class PathOfTravel : public Element

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.AnalysisPathOfTravel

See Also