MEPSystemType Class


A system type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public class MEPSystemType : ElementType
Visual Basic
Public Class MEPSystemType _
	Inherits ElementType
Visual C++
public ref class MEPSystemType : public ElementType

Remarks

This is the base class for mechanical and piping system types, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBMEPSystemType
        Autodesk.Revit.DB.MechanicalMechanicalSystemType
        Autodesk.Revit.DB.PlumbingPipingSystemType

See Also