GetCellCategoryId Method (Int32, Int32)


Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetCellCategoryId(
	int nRow,
	int nCol
)
Visual Basic
Public Function GetCellCategoryId ( _
	nRow As Integer, _
	nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
	int nRow, 
	int nCol
)

Parameters

nRow
Type: SystemInt32
nCol
Type: SystemInt32

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also