OnDuplicateTypeNamesFound Method


Called when the destination document contains types with the same names as the types being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
DuplicateTypeAction OnDuplicateTypeNamesFound(
	DuplicateTypeNamesHandlerArgs args
)
Visual Basic
Function OnDuplicateTypeNamesFound ( _
	args As DuplicateTypeNamesHandlerArgs _
) As DuplicateTypeAction
Visual C++
DuplicateTypeAction OnDuplicateTypeNamesFound(
	DuplicateTypeNamesHandlerArgs^ args
)

Parameters

args
Type: Autodesk.Revit.DBDuplicateTypeNamesHandlerArgs
The information about the types with duplicate names.

Return Value

The action to be taken: copy only types with unique names or cancel the operation.

See Also