DirectShapeType Class


The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public class DirectShapeType : ElementType
Visual Basic
Public Class DirectShapeType _
	Inherits ElementType
Visual C++
public ref class DirectShapeType : public ElementType

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBDirectShapeType

See Also