ConnectDuctPlaceholdersAtElbow Method (Document, ElementId, ElementId)


Connects a pair of placeholders that can intersect in an Elbow connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtElbow(
	Document document,
	ElementId placeholder1Id,
	ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtElbow ( _
	document As Document, _
	placeholder1Id As ElementId, _
	placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtElbow(
	Document^ document, 
	ElementId^ placeholder1Id, 
	ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
placeholder1Id
Type: Autodesk.Revit.DBElementId
The element id of the first duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DBElementId
The element id of the second duct placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders must meet at a physical end connection. If connection fails, the placeholders cannot be physically connected.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder1Id and placeholder2Id are not physically connected.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also