Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- overallWidth
- Type: SystemDouble
The entire width of the wire sheet in the minor direction.
- minorStartOverhang
- Type: SystemDouble
The distance from the edge of the sheet to the first wire in the minor direction.
- minorEndOverhang
- Type: SystemDouble
The distance from the last wire to the edge of the sheet in the minor direction.
- spacing
- Type: SystemDouble
The distance between the wires in the major direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for minorEndOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for minorEndOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet. |