SetVertexConnectionMap Method


Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVertexConnectionMap(
	VertexIndexPairArray vertexMap
)
Visual Basic
Public Sub SetVertexConnectionMap ( _
	vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
	VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DBVertexIndexPairArray

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-"vertexMap"-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the document failed to regenerate.

See Also