CreateRibbonPanel Method (String, String)


Create a new RibbonPanel on the specified tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
	string tabName,
	string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
	tabName As String, _
	panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
	String^ tabName, 
	String^ panelName
)

Parameters

tabName
Type: SystemString
The name of the tab, on which the new panel will be created.
panelName
Type: SystemString
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptiontabName or panelName is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptiontabName or panelName is Empty.
Autodesk.Revit.ExceptionsInvalidOperationExceptionToo many panels have been added to this tab (Maximum is 100).

See Also