CycleCounterChanged Property


True if the cycle counter was changed, false otherwise.

The cycle counter value is changed when the free form Rebar element is selected and the user press Space key -or- by through [!:Autodesk::Revit::DB::Structure::RebarRebarFreeFormAccessor::CycleCounter] property. -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool CycleCounterChanged { get; }
Visual Basic
Public ReadOnly Property CycleCounterChanged As Boolean
	Get
Visual C++
public:
property bool CycleCounterChanged {
	bool get ();
}

See Also