GetBearerCenterline Method


Gets the centerline of the bearer. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public Line GetBearerCenterline()
Visual Basic
Public Function GetBearerCenterline As Line
Visual C++
public:
Line^ GetBearerCenterline()

Return Value

The centerline of the bearer.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException The hanger is not a bearer hanger.

See Also