AddTriangles Method


Inserts multiple IndexTriangle instances into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddTriangles(
	IList<IndexTriangle> triangles
)
Visual Basic
Public Sub AddTriangles ( _
	triangles As IList(Of IndexTriangle) _
)
Visual C++
public:
void AddTriangles(
	IList<IndexTriangle^>^ triangles
)

Parameters

triangles
Type: System.Collections.GenericIListIndexTriangle
The triangles to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also