SystemId Property


The optional MEP system element id where the iterations are restricted.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId SystemId { get; set; }
Visual Basic
Public Property SystemId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ SystemId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also