Sets an instance of ICustomFieldProperties which represents the properties of this field.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- customFieldProperties
- Type: Autodesk.Revit.DBICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input properties are not valid. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Can't set the properties to a CustomFieldData of a SchedulableField (which is not added to a schedule). |