SetCurve Method


Sets the curve for the Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public void SetCurve(
	Curve curve
)
Visual Basic
Public Sub SetCurve ( _
	curve As Curve _
)
Visual C++
public:
void SetCurve(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DBCurve

Remarks

End nodes connection will be lost if the curve changes position. The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input curve is not bound. -or- The provided curve is not supported.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also