GetAnalyticalSegment Method


Gets the analytical segment at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPAnalyticalSegment GetAnalyticalSegment()
Visual Basic
Public Function GetAnalyticalSegment As MEPAnalyticalSegment
Visual C++
public:
MEPAnalyticalSegment^ GetAnalyticalSegment()

Return Value

The retrieved segment, may be null for the first step.

See Also