Checks if given type is valid flexible duct type.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- ductTypeId
- Type: Autodesk.Revit.DBElementId
ElementId of the flexible duct type to check.
Return Value
True if flexible duct type can used for this duct, false otherwise.Remarks
A type is valid for flexible duct if it can be used to the flexible duct element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |