GetFluidType Method


Gets the fluid type of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId GetFluidType(
	FabricationService service
)
Visual Basic
Public Function GetFluidType ( _
	service As FabricationService _
) As ElementId
Visual C++
public:
ElementId^ GetFluidType(
	FabricationService^ service
)

Parameters

service
Type: Autodesk.Revit.DBFabricationService
The service to lookup.

Return Value

The fluid type id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException service is not mapped to a fluid type and temperature.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also