SetEndReference Method


Sets the end reference of a framing element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static void SetEndReference(
	FamilyInstance familyInstance,
	int end,
	Reference pick
)
Visual Basic
Public Shared Sub SetEndReference ( _
	familyInstance As FamilyInstance, _
	end As Integer, _
	pick As Reference _
)
Visual C++
public:
static void SetEndReference(
	FamilyInstance^ familyInstance, 
	int end, 
	Reference^ pick
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete and joined.
end
Type: SystemInt32
The index of the end (0 for the start, 1 for the end).
pick
Type: Autodesk.Revit.DBReference
The reference to set to the given end.

Remarks

The setback value will be changed as a result of the removal.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException end must be 0 or 1.
Autodesk.Revit.ExceptionsArgumentsInconsistentException The input familyInstance is not of a structural framing category or is concrete or is not joined at given end and cannot have an end reference set. -or- The input pick cannot be set as the end reference for the given end of the structural framing element.

See Also