The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.CreationFamilyItemFactory
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.CreationFamilyItemFactory