SetOptions Method


Sets the options to use for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public void SetOptions(
	DirectShapeTypeOptions options
)
Visual Basic
Public Sub SetOptions ( _
	options As DirectShapeTypeOptions _
)
Visual C++
public:
void SetOptions(
	DirectShapeTypeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DBDirectShapeTypeOptions
Options to use for this DirectShapeType.

Remarks

The new options take effect immediately.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The DirectShapeTypeOptions provided are not valid for this DirectShapeType.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also