SupportSpacing Property


The support spacing of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double SupportSpacing { get; set; }
Visual Basic
Public Property SupportSpacing As Double
	Get
	Set
Visual C++
public:
property double SupportSpacing {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The given value for supportSpacing must be between 0 and 30000 feet.
Autodesk.Revit.ExceptionsInvalidOperationException When setting this property: The rail has no support or the support has inappropriate layout so the data being set is not applicable.

See Also